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Abstract — This study involves the structural analysis and 

design of curved structures, such as roofs and bridges, 

utilizing STAAD Pro software to evaluate their performance 

under various load conditions, including wind and gravity 

loads. This design mainly stimulates from the design on CAD 

designs. 

The process entails creating a 3D model, defining geometric 

properties and structural loads, and conducting ananalysis to 

determine internal forces like bending moments and shear 

forces. The results then inform the design of members to meet 

strength and serviceability requirements, often comparing 

curved structures to their straight counterparts and 

highlighting STAAD Pro efficiency for complex geometries 

and large-span projects. 

These projects are mainly used for different types of structures 

in the construction field. It also proves that these types of 

designs give different type of view for the buildings and in 

their architecture point of view. 

 

Index Terms — Curved structures, STAAD.Pro, Aesthetic 

and Structural Efficiency, Modelling Curved Elements, Load 

Considerations, Comparison with Straight Structures, 

Performance Evaluation. 

 

I. INTRODUCTION 

Curved structures represent one of the most elegant and efficient 

forms in structural engineering. Unlike straight members, 

curved beams, arches, domes, and shells distribute loads more 

naturally, often reducing bending stresses and enhancing 

stability. Their geometry allows architects and engineers to 

achieve both aesthetic appeal and structural economy, making 

them popular in bridges, stadium roofs, auditoriums, and 

modern architectural landmarks. 

STAAD Pro, as a versatile structural analysis and design 

software, provides the computational power to handle these 

complex geometries. By using its finite element modeling 

capabilities, engineers can simulate how curved members 

respond to different loads : dead, live, wind, or seismic and 

evaluate stresses, deflections, and stability. The software 

integrates international design codes, enabling engineers to 

check compliance automatically and optimize sections for 

safety and cost-effectiveness. 

When analyzing curved structures in STAAD Pro, the focus is 

not on linear step-by-step commands but on understanding the 

behavior of curved geometry under loads. Curved beams 

experience combined bending and axial forces, arches rely on 

compression for strength, and shells distribute loads across 

their surfaces. STAAD Pro’s ability to model these behaviors 

in three dimensions makes it invaluable for engineers working 

on projects where precision and efficiency are critical. 

II. LITERATURE REVIEW 

A. Shaowei Xu (2024) Research on Topology Optimization 

Design of Truss Structure This study uses topology 

optimization to improve truss designs, reducing material 

usage while ensuring load bearing efficiency. It focuses on 

achieving sustainable and cost-effective structural solutions. 

Simulations demonstrate the advantages of optimized trusses 

for complex load distributions. 

 

B. Singh, Roy (2023) Effects of Roof Slope and Wind 

Direction on Wind Pressure in Low-Rise Buildings This 

research explores how roof angles and wind directions affect 

wind pressure distribution. Pitched roofs experience higher 

uplift forces, requiring special design considerations. The 

study offers valuable insights for improving roof stability 

under strong winds. 

C. Watane, Dahat (2023) Comparative Study on Pratt and 

Howe Trusses Using STAAD Pro This paper evaluates Pratt 

and Howe trusses using STAAD Pro, finding that Howe 

trusses are more stable for longer spans. Pratt trusses perform 

better for shorter spans. The results guide efficient truss 

selection for various structural needs. 

 

D. Parthasaarathi R., Kabilan G., Karthick V., Chandru D., 

Dhamotharan K. (2022) Comparative Study on Analysis and 

http://www.jsetms.com/
http://doi.org/10.64771/jsetms.2026.v03.i04(1).pp139-144
mailto:Shruthi.t@kpritech.ac.in1
mailto:Sowmyamalisetti994@gmail.com2
mailto:adansunay143@gmail.com4
mailto:manasasingireddy24@gmail.com5
https://staad.pro/


Journal of Science Engineering Technology and Management Science                             ISSN:3049-0952 

Volume03,Issue04(1),April2026                                                                                                    www.jsetms.com 

 

140 | Page 

 

 

 

Design of Structural Steel Elements with Indian and 

American Codes This paper compares steel structures 

designed with Indian (IS 800) and American (AISC 360) codes 

 

using STAAD.Pro. It highlights differences in stress ratios, 

deflection, and bending moments, showing that AISC designs 

often provide higher strength. The study aids in selecting 

standards for safe and economical structures. 

E. Peng et al. (2022) Reliability Analysis of Large Curved 

Roofs Under Wind and Snow This study evaluates curved 

roofs under combined wind and snow loads using 

computational models. The findings reveal high- risk 

scenarios, prompting design improvements. The research 

enhances roof resilience to extremeweather. 

 

F. Prabhodana (2020) Design and Analysis of Industrial 

Warehouse This paper uses STAADPro to design industrial 

warehouses, ensuring efficient load management and 

compliance with IS codes. The results demonstrate cost- 

effective and safe designs. It highlights STAAD.Pro's 

capabilities for large industrial structures. 

 

G. Bhattacharyya, Dutta (2019) Comparative Analysis of 

Pratt and Howe Trusses This research compares Pratt and 

Howe trusses, showing Howe trusses are better for longer 

spans. Pratt trusses are more suitable for shorter spans. The 

study helps in selecting trusses for different structural needs. 

 

H. Babu et al. (2019) Design of Curved Arch Truss for 

Auditorium Hall This study optimized curved truss designs, 

finding pipe sections more stable and economical than tube 

sections. STAAD.Pro analysis demonstrated improved 

efficiency. The findings aid in cost-effective auditorium roof 

design. 

 

I. Baby et al. (2019) Space Truss Design Using STAAD.Pro 

This research designed space trusses for large open spans, 

ensuring durability and material efficiency. STAAD.Pro was 

effective in modeling these structures. The results support 

space trusses for arenas and exhibition halls 

 

III OBJECTIVES 

1. Generation of structural framing plan. 

2. Creation of model of structure in STAAD PRO 

3. Application of various load combinations on the member. 

4. Analysis of the structure. 

5. Design of the structure. 

6. Useful for the high-end structure. 

7. It is a more efficient way of building the structure. 

8. It shows us different ways structure and its application. 

IV. METHODOLOGY 

 

 STRUCTURE 

ASTRUCTURE can be defined as an assemblage of elements. 

STAAD is capable of analyzing and designing structures 

consisting of both frame and Finite elements. Almost any 

type of structure can be analyzed by STAAD. 

Frame elements Beam elements – 2 nodes Finite elements 

1) Plate -3 or 4 nodes 

2) Solid – 4 to 8 nodes 

In case of STAAD: 

Nodes becomes Joint (it has a number and xyz coordinates) 

Beam 

Becomes Member (it has a number and nodes at its ends) Plate 

Becomes Element (it has a number and node at its corners) 

 

 TYPES OF STRUCTURE

A TRUSS structure consists of truss members which can have 

only axial member forces and no bending in the members. 

A PLANE structure is bound by a global X-Y coordinate system 

with loads in the... (The sentence is incomplete in the extracted 

text). 

Additional context from the AI-Enhanced Description: 

The presentation's content description indicates that the slides 

(5-6) on "Understanding Structures" cover: 

Definition of structures and classification into truss, plane, 

space, and floor types. 

 COMMANDS USED IN STAAD.PRO:

 

1. Snap Node/Beam 

2. Nodes cursor 

3. Plates cursor 

4. Add beam 

5. Add 4 node plates 

6. Add surface 

7. Insert node and its application 

8. Shift+ B - shows the number of beams 

9. Shift+ N - shows the number of nodes 

10. Translational Repeat-This command is usually used to 

repeat the element in liner direction 

11. Circular Repeat-This command is usually used to repeat the 

element in radial direction 

12. Member Load – It is adopted only on horizontal members 

and vertical members 

 

Open page of the STAAD.Pro 

 
 COMMANDS USED IN CURVED STRUCTURE: 

1. GEOMETREY 

http://www.jsetms.com/
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2. TRANSLATIONAL REPEAT 

3. CUT SECTION 

4. CREATE RENDERING VIEW 
5. ADD PROPERTIES 

6. SUPPORTS 

7. LOAD CASES DETAILS 

8. SELECT PARAMETERS 

9. DEFINE PARAMETERS 

10. DESIGN COMMANDS 
11. ANALYSIS AND PRINT 

12. CIRCULAR REPEAT 

Interface of the STAAD.Pro 
 

Points to be remember while designing: 

• First draw the structure to be designed using nodes, beams, 

plates and surfaces. 

• While drawing important thing to be considered is first 

complete the small element of the portion then repeat that 

for a whole structure. 

• Then assume the material, properties, dimensions of the 

elements. 

• Then define various loading conditions. 

• At last, analyze the structure. 

TOOLS USED 

 
All these options is used to see the view of structure from 

various side 
 

 
Rotation can be done by rotating the options 

 

 

To zoom the structure and return of previous these are required 
 

If you want to return the whole structure use this 

 
To see the 3D render view use option 

 

3D Modeling 

The process begins by creating a detailed 3D model. A key 

technique is to simulate the curve using a series of straight-line 

segments (a piecewise model). 

Defines the precise geometry based on initial CAD plans. 

 

This "straight segment" method allows for detailed analysis, as 

STAAD.Pro's native "curved beam" element has limitations. 

 

Material properties (e.g., concrete, steel) are assigned. 
 

 

Strength Requirements: The analysis results are used to inform 

the final design. Members are sized to meet strength 

requirements based on the calculated internal forces (moments, 

shear). 

 

Serviceability: The structure is checked to ensure it meets 

serviceability requirements, such as limits on deflection, to 

ensure user comfort and structural integrity. 

Code Compliance: The final design is verified against relevant 

building codes and standards (e.g., IS 456) to ensure safety and 

compliance. 

Key Aspects of Curved Structures: - 

 

 

Aesthetic & Structural Efficiency 

Curved forms are not just for aesthetics; they can be highly 

efficient in distributing loads, especially for large-span projects 

Modeling & Load Complexity 
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Accurately modeling the curved elements and considering the 

unique, often asymmetrical, impact of wind loads are the 

primary challenges. 

 

The Role of STAAD.Pro 

“STAAD.Pro shows high efficiency for complex 

geometries and large-span projects” 

 
V. CURVED STRUCTURES 

 
1. Click on STAAD.Pro icon → Select New Project → Select 

Space → Select File Name → Select Location → Select Unit 

→ Click on Next → Click on Finish. 

2. User interface opens with grid system → Keep it in Front 

View → Go to Edit option in Grid 

→ Change the length and breadth to 5m → Click on OK 

3. Click on Snap/Grid option → Select node 0 to 30 m in Y 

direction → Select node 5 to 10 m in X direction → Join the 

nodes in X direction up to 0 to 30 m in Y direction → The 

shape becomes Rectangle. 

4. Click on Snap/Grid option → Select a node 0 to 30 m in Y 

direction → Remove the default grid setting. 
5. Click on Circular Repeat → Select axis of rotation (Y- 

direction) → Enter Total Angle (e.g., 160°) → Enter Number of 

Steps (e.g., 5) → Select node to point the centre of structure → 

Click on Link Steps → OK. 

6. Click on whole structure → Place in the Isometric View → 
Delete / Remove the centre beam. 

7. Keep the structure in front view → Delete / Remove the 

bottom beam of structure. 

8. Select the second beam from the bottom → Click on Cut 

Section → Click on Select to View 

→ Click on OK → Select the second beam from the bottom. 
9. Keep it in Isometric view → Select 4 noded plates → Select 

the nodes of 5 steps → Click on Whole Structure → Select the 

plate cursor → Select whole structure. 

10. Click on Translational Repeat → Select Y direction → 
Select No. of steps → Set the spacing → Click on Link Steps 

→ Click on OK. 

11. Click on General → Select Support → Keep the structure in 

front view → Click on Create 

→ Select Fixed Support → Click on Add. 

12. Select the support → Click on Assign → Use cursor to 

assign → Click on Assign. 

13. Click on Material → Select Concrete → Click on Create 

→ Select title as Concrete in display bar → Edit title as M20 

→ Change the density as 25 → Click on Add → Close. 

14. Now add M20 grade by selecting Assign to View → OK. 

15. Go to Property → Select Define → Select Circular → Circle 

dimensions 600 mm in Y- direction → Select material as M20 

→ Click Add. 

16. Select Rectangle dimensions 600 mm in Y-direction and 

400 mm in Z-direction → Select material as M20 → Click on 

Add → Click on Close. 

17. Select Thickness → Click on Plate Element Thickness → 

Select value as 0.15 m → Click on Add → Click on Close. 

18. Go to Select → Click Beams Parallel to X → Select Control 

button and select beams parallel to Z-direction → Now click 

Assign to Selected Beams → Click on Assign → OK. 

19. Similarly assign to columns by selecting beams parallel to 

Y-direction. 

20. Assign plate thickness by clicking Assign to View. 

21. Go to Load & Definition → Select Load Case Details → 

Click on Add → Select loading type as Dead → Type title as 

DL → Click on Add → Select loading type as Live → Type LL 

→ Click on Add. 

22. Select Dead Load → Click on Add → Select Self Weight → 

Click on Add → Close → Now assign by selecting Assign to 

View → Assign → OK. 

23. Select Live Load → Click on Add → Select Floor Load → 

Add Pressure [-5] → Min 5 m to Max 30 m. 

24. Repeat for Floor Load → Add Pressure [-1.5] → Min 5 m 

to Max 30 m. 

25. Assign them to the structure. 
 

 

 

26. Go to Analyze & Print → Click on All → Save. 

27. Go to Analyze → Run Analysis → Check Errors. 
 

 

 DESIGN PART 

 Click on deign → select concrete on left side → select IS 

456 on right side 

 Go design parameters → click on left side arrow mark → 

select Fc –compressive strength of concrete, fymain and 

Fysec and select right arrow → click on ok. 
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 Go to design parameters → click on Fc main and select 

grade of concrete (20 N/mm
2
) 

 → select Fymain and select grade of steel (415 N/mm
2
) → 

select Fysec and select grade of steel (415 N/mm
2
) → click 

on OK → click on close 

 Go to design parameters → select design beam → select 

deign column→ click on ok. 
 

 

 → close 

 Now assign all by selecting assign to view 

 Go to analysis and print → analyze →run analysis 
 

 

VI. LIMITATIONS AND FUTURE SCOPE 

 

 Limitations of curved structure 

 Linear Static Analysis: The current project likely focuses 

on linear static analysis. In reality, curved structures 

(especially large-span ones) may exhibit non-linear 

behaviour under heavy loads or extreme weather, which 

was not accounted for. 

 Idealized Support Conditions: The supports are likely 

modelled as perfectly "Fixed" or "Pinned." In actual field 

conditions, soil-structure interaction and the flexibility of 

the foundation can significantly alter the stress 

distribution. 

 Environmental Factors: The study primarily focuses on 

Gravity (Dead/Live) loads. It may not have deeply 

integrated complex Dynamic Loads such as fluctuating 

wind gusts (vortex shedding) or site-specific seismic time- 

history analysis. 

 Material Assumptions: The analysis assumes concrete and 

steel are perfectly homogeneous and isotropic. It does not 

account for long-term effects like creep, shrinkage, or 

thermal expansion which are critical for curved concrete 

geometries. 

 

 Future Scope 

 P-Delta Analysis: Future studies could perform P-Delta 

analysis to account for secondary moments caused by the 

displacement of the curved members under high axial 

loads. 

 Dynamic and Seismic Evaluation: The project could be 

expanded to include Response Spectrum Analysis or Time 

History Analysis to observe how the curved structure 

behaves during an earthquake. 

 Optimization of Curvature: A parametric study could be 

done to find the "Optimum Radius" of curvature that 

provides the highest strength-to-weight ratio, potentially 

saving more material. 

 Implementation of BIM: Integrating the STAAD.Pro 

model with BIM (Building Information Modelling) 

software like Revit could help in detailed 3D 

reinforcement detailing and 4D construction scheduling. 

 Wind Tunnel Testing: For very large curved roofs (like 

stadiums), physical scale-model testing in a wind tunnel 

or Computational Fluid Dynamics (CFD) analysis could 

be used to validate the STAAD.Pro wind load results. 

 

VII. RESULTS 

 

• 3D rendering view of the structure. 

 

 

 

VIII. CONCLUSION 

 

Curved roof trusses are highly efficient in distributing loads 

evenly, reducing stress concentrations compared to flat or 

pitched roofs, making them ideal for large-span structures like 

stadiums and airports. STAAD.Pro simplifies the design and 

analysis process by accurately simulating complex load 

combinations and providing detailed insights into stress, 

deflection, and stability. Curved roofs demonstrate superior 

performance under wind and dynamic loads due to their 

aerodynamic shape, making them suitable for regions prone to 

high winds or seismic activity. 

The geometry of curved trusses allows for significant material 

savings,  reducing  project  costs  without  compromising 
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structural integrity, especially when advanced materials are 

used. Beyond structural benefits, curved roofs offer aesthetic 

appeal and sustainability advantages, such as improved natural 

lighting, ventilation, and energy efficiency, aligning with 

modern architectural and environmental goals. 
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